Help BBC news web pages not displaying properly

Discussion in 'computers, web and general tech' started by skyscraper101, Jul 8, 2018.

  1. skyscraper101

    skyscraper101 0891 50 50 50

    Whats going on here? Everytime I click on a link from the main BBC News homepage, I get a page looking like this.

    It's been like this for days on firefox and chrome. Only seems to work properly on Safari. Can I fix this?

    Screen Shot 2018-07-08 at 14.16.53.png
     
  2. Puddy_Tat

    Puddy_Tat for the workers' breakfast

    seems ok where i am sitting (firefox 61.0.1 on windows 7) - i don't have chrome on the computer so can't check that.

    this looks like a javascript issue.

    have you disabled javascript? or not got latest firefox? or latest java?
     
  3. salem

    salem Well-Known Member

    Odd, looks like the CSS hasn't loaded. Try pressing the refresh button while holding down your shift key.
     
  4. skyscraper101

    skyscraper101 0891 50 50 50

    I haven't disabled anything. I have the latest firefox 61.0.1. How do I check I have the latest java?

    Tried that, same thing.

    So far this only happens on links I click on the BBC site. Not the actual main page which is fine. Really odd.

    ETA, this is on a mac running OSX 10.13.5 High Sierra
     
  5. Puddy_Tat

    Puddy_Tat for the workers' breakfast

  6. skyscraper101

    skyscraper101 0891 50 50 50

  7. Puddy_Tat

    Puddy_Tat for the workers' breakfast

    oh.

    :(
     
  8. skyscraper101

    skyscraper101 0891 50 50 50

    This is really annoying. All other webpages work fine. What the flip is the problem with the BBCs page loading?
     
  9. planetgeli

    planetgeli There's no future in England's dreaming

    Probably not helpful at all but last year I had a problem with BBC images not loading and it wasn’t the BBC’s fault at all. It was because I had a piece of shit called kaspersky which had unilaterally decided it was going to mess with BBC stuff.
     
    skyscraper101 likes this.
  10. skyscraper101

    skyscraper101 0891 50 50 50

    hmm.. I'm starting to think I have something which is messing specifically with the BBC. I just did a cross check on other similar sites like CNN and Guardian and they're fine.
     
  11. skyscraper101

    skyscraper101 0891 50 50 50

    OK I think I've found the problem. My VPN client. :facepalm:

    Once I disconnected it, all the BBC sites ran fine. I've now reconnected it - specifically to a UK VPN - and it still works. What was that all about then?
     
  12. pinkychukkles

    pinkychukkles Feed Your Head

    Yes! I was / am having the exact same issue too, across both FF and Chrome on laptop.
    Suspected it could be to do with my VPN client (PIA), I would always have to disconnect it when using my phone if I wanted to view World Cup matches via the BBC Sport app. On my laptop, I've found that closing and re-opening my browser seems to fix it without having to disconnect the VPN.

    This is also with my VPN connected to a UK node too, think that the BBC have got PIAs number or at least some / most of their IP addresses blocked possibly.
     
    skyscraper101 likes this.
  13. keybored

    keybored #NeverUseTheInternetAgain

    Similar here, BBC won't load properly. I'm also using VPNs but it was working fine before upgrading FF to 61. Still not loading with VPN disconnected.

    Are you also on OSX?
     
  14. skyscraper101

    skyscraper101 0891 50 50 50

    Yep PIA too. Opening and closing the browser didn't work for me. Disconnecting PIA did. As did reconnecting to a different country (I chose UK just to be sure, I haven't checked other countries yet).
     
  15. skyscraper101

    skyscraper101 0891 50 50 50

    Yeah on OSX. Disconnecting the VPN seemed to fix it though in my case - both with no VPN, and then reconnecting to a UK VPN. I didn't run extensive testing after though so I don't know what exactly the issue is.
     
  16. keybored

    keybored #NeverUseTheInternetAgain

    No VPN connected, fresh private window.

    Screen Shot 2018-07-09 at 14.04.51.png

    Other sites all seem normal too.
     
  17. skyscraper101

    skyscraper101 0891 50 50 50

    Really weird eh. I get no problems on a Windows 10 machine FWIW. This seems to be a Mac OSX problem?
     
  18. keybored

    keybored #NeverUseTheInternetAgain

    Broken on Chrome too, fine on Safari even with Romania VPN. I refuse to use Safari so fuck you BBC.
     
    skyscraper101 likes this.
  19. skyscraper101

    skyscraper101 0891 50 50 50

    Have you tried on a non-private window? Same issue?
     
  20. keybored

    keybored #NeverUseTheInternetAgain

    Yeah, I only tried private in case something in my cache was causing it (and before discovering Chrome is having the same issue).
     
  21. pinkychukkles

    pinkychukkles Feed Your Head

    Hmmm, so appears it's an OS X (or macOS) issue; am running 10.11.6 El Capitan.
    I initially thought it was an extension / add-on issue but didn't have the time / couldn't be arsed to troubleshoot which one it may have been.
     
  22. keybored

    keybored #NeverUseTheInternetAgain

    Seems to have quietly resolved itself (now working on Chrome and FF, with or without VPN) and I haven't updated anything so I'm guessing it was a site issue.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice